3 года назад

Извлечение данных из справочника в Exsel из 1с 7.7?

Нашел какую то обработку . у нее такие ошибки1) если дата пустая то в excel переносит 12.00.00 AM2)если реквизит с типом строка или число не заполнен переносит ноль3) если реквизит пренадлежит другому справочнику то выдает ошибку    например    xl.Cells(ow,14).Value=спр.Тариф.Наименование;    {Обработка.новый1.Форма.Модуль(24)}: Поле агрегатного объекта не обнаружено (Наименование)4)сама обработка     Процедура Выполнить()    xl=СоздатьОбъект("Excel.Applicatio");    xl.Wokbooks.Add();    xl.Visible=1;    ow=1;    спр=СоздатьОбъект("Справочник.Абоненты");    спр.ВыбратьЭлементы();    Пока спр.ПолучитьЭлемент() = 1 Цикл        xl.Cells(ow,1).Value=спр.Наименование;
xl.Cells(ow,2).Value=спр.Улица.Наименование;
xl.Cells(ow,3).Value=спр.Дом;
xl.Cells(ow,4).Value=спр.Квартира;
xl.Cells(ow,7).Value=спр.Телефон;
xl.Cells(ow,8).Value=спр.Документ;
xl.Cells(ow,9).Value=спр.Серия   ;
xl.Cells(ow,10).Value=спр.Номер ;
xl.Cells(ow,11).Value=спр.Выдан ;
xl.Cells(ow,12).Value=спр.СтарыйАдрес;
xl.Cells(ow,13).Value=спр.ДатаПереезда;
xl.Cells(ow,14).Value=спр.Комментарий;
xl.Cells(ow,14).Value=спр.Тариф.Наименование;
       ow=ow+1 ;    КонецЦикла;КонецПроцедуры6)Помогите исправить код чтоб ошибок небыло.

Первоход (Гость) Excel
3

Excel: Извлечение данных из справочника в Exsel из 1с 7.7?

9 месяцев назад подскажите формулу в excel для объединения данных несмежных ячеек

Требуется объединить содержимое нескольких ячеек без потери данных. Функция СЦЕПИТЬ не устраивает тем, что между присоединяемыми кусочками ставит пробелы. Мне нужны ;
да бог с ними, с пробелами. Мне точка с запятой нужна
М. Алексей помог! Спасибо ему

Атарик (Гость) 3 ответа
3
8 месяцев назад Импорт данных из одной таблицы в другую по ключевому столбцу

Добрый день, проблема в следующем:есть 2 таблицы, в каждой есть столбец с id товара, и столбцы с характеристиками, соответствующими этому товару. Нужен простой способ перенести характеристики из одной таблицы в другую так, чтобы они соответствовали id товара. Сортировка не канает, в столбцах с id данные не полностью идентичны.

Сергей Лопатин (Гость) 2 ответа
3
8 месяцев назад Автозаполнение данных Excel

Начало: есть 2 листа Excel, в первом данные уже введены, а во второй нужно вводить то-же самое, только таблица другая, просто скопировать и вставить не получится. В первом листе ячейка с номером рядом с ячейкой со значением. Для примера -             |    1   |   2.5  |                                                  ...

Ctrl-S (Гость) 3 ответа
3
Ответы (3)
Nurlan B (Гость) 3 года назад
3

Ну я бы прописывал обработку ошибок в цикле, типа если дата пустая - то в ячейку писать "", иначе значение из справочника.

Насчет подчиненного справочника - я не знаток кода 1С, но могу предположить, что его тоже надо как-то объявить (через СоздатьОбъект).
Повторюсь, я совсем не знаток кода 1С, поэтому могу и глупости писать.

Чем могу, как говорится.

Пожаловаться
Super Kyper (Гость) 3 года назад
3

// Смотри комментарии в коде

Процедура Выполнить()
\t
\txl\u003dСоздатьОбъект("Excel.Application");
\txl.Workbooks.Add();
\txl.Visible\u003d1;
\t
\trow\u003d1;
\tспр\u003dСоздатьОбъект("Справочник.Абоненты");
\tспр\u003dСоздатьОбъект("Справочник.Номенклатура");
\tспр.ВыбратьЭлементы();
\t
\tПока спр.ПолучитьЭлемент() \u003d 1 Цикл
\t\t
\t\tПопытка
\t\t\t\t\t
\t\t\txl.Cells(row,1).Value\u003dспр.Наименование;
\t\t\t
\t\t\t//прежде, чем прочитать реквизит объектного типа - проверяем, что он заполнен
\t\t\tесли ПустоеЗначение( спр.Улица.ТекущийЭлемент() )\u003d0 тогда
\t\t\t\txl.Cells(row,2).Value\u003dспр.Улица.Наименование;
\t\t\tконецесли;
\t\t\t
\t\t\t//Не записываем в ячейку excel, если пустое поле.
\t\t\t//Для остальных колонок, при необходимости, сделать по аналогии
\t\t\tесли СокрЛП(спр.Дом) \u003c "" тогда
\t\t\t\txl.Cells(row,3).Value\u003dспр.Дом;
\t\t\tконецесли;
\t
\t\t\txl.Cells(row,4).Value\u003dспр.Квартира;
\t\t\txl.Cells(row,7).Value\u003dспр.Телефон;
\t\t\txl.Cells(row,8).Value\u003dспр.Документ;
\t\t\txl.Cells(row,9).Value\u003dспр.Серия ;
\t\t\txl.Cells(row,10).Value\u003dспр.Номер ;
\t\t\txl.Cells(row,11).Value\u003dспр.Выдан ;
\t\t\txl.Cells(row,12).Value\u003dспр.СтарыйАдрес;
\t\t\txl.Cells(row,13).Value\u003d Формат(спр.ДатаПереезда,"Д ДДММГГГГ");
\t\t\txl.Cells(row,14).Value\u003dспр.Комментарий;
\t\t\t
\t\t\tесли ПустоеЗначение( спр.Тариф.ТекущийЭлемент() )\u003d0 тогда
\t\t\t\txl.Cells(row,15).Value\u003dспр.Тариф.Наименование;
\t\t\t\t//тут остальное про Тариф
\t\t\t\t//...
\t\t\tконецесли;
\t\t
\t\t\t//...
\t\t\trow\u003drow+1;
\t\t
\t\tИсключение
\t\t\t
\t\t\t//смотрим ошибки
\t\t\tСообщить("Ошибка в строке "+row+": "+ОписаниеОшибки(),"!");
\t\t\t//продолжаем выгрузку
\t\t\trow\u003drow+1;
\t\t\t
\t\tКонецПопытки;
\t\t
\tКонецЦикла;
\t
\t//...
\t
КонецПроцедуры

Пожаловаться
Яроша (Гость) 3 года назад
3

Если нужно полностью видеть справочник в Excel, то можно в файле 1cv7.DD найти по имени справочника нужный файл DBF, открыть его в Excel и удалить лишние колонки, после чего сохранить как xls.

Пожаловаться
Извлечение данных из справочника в Exsel из 1с 7.7? (Excel) - вопросы и ответы на все случаи жизни - справочник Excel i-vopros.ru